GPG 加密
了解如何使用 GPG 密钥发送加密消息。
1. 关于 GPG
GPG (GNU Privacy Guard) 是一种加密工具,它使用公钥加密技术对数据和通信内容进行安全加密与数字签名。
使用我们的公钥,您可以向我们发送加密消息,并安全地传输和签署文档。
由于技术限制,我们目前只能以未加密的普通邮件形式进行回复。在此情况下,未加密的回复邮件中也会包含您原始消息的未加密文本。
2. netcup GPG 公钥
-----BEGIN PGP PUBLIC KEY BLOCK----- Version: GnuPG v1.4.10 (GNU/Linux) mQENBFJmDgoBCADFDphhP/VLswsUwv3k/Nf6N7XJe7XcmxR7VcJSN9h6KnrwH/fF gr0bNX4vt1eQJxYEtq4yx6kXwT3cxm1X9gqQ1d/nqayO8G30XK3ZgWjfX6ZpYs63 yaPxBIOqPtXcyL6150GoNgP9zqZmv9duYDdySXx+HI66aGQxDAU+7FxmyxzQTGY8 8GG+eQmx6cEUQDqBe6SdQYTU7EziCjteRA1H16IBD9CUrndiquYSoToBfymNL/tf JxcqkjVdpG6U/HftSnw3j/n829a0SiwNArtYJlov9QrvjSFNu5qichas86uO0Zv2 xrrQ5vDA7Kp/E+U1fisVGpas3brAttq2H0GnABEBAAG0HG5ldGN1cCBHbWJIIDxt YWlsQG5ldGN1cC5kZT6JATgEEwECACIFAlJmDgoCGwMGCwkIBwMCBhUIAgkKCwQW AgMBAh4BAheAAAoJEHdq8NoKj1HkZB4IAMIP5/0tKagq05WSWuH4xAZDeBLclCi2 B6n+zfKBStmZHPcizsXUZSsWIwmBrL4A9H3T/TFO06NDcdoVd5kqBIGE2ByA3DAh 4ljRb1XWu8ph2eHTiy/LV9irYuQ0rBGOUNUp/QGDj770XIKYwCa6dCSdOpKuZcqq 8UVZjXY62aNt0AtM9eUPah0CGwQY3bEUMm/DyXceLC51X740ygrVkes+9YMFLM0w gbAim82hvIzdlsPEHLItlqmSNvdvKe6DnBfbiR5hnCXZ56a+pQFdmBjMa7eZZY3l LxfkqlRpUUfsPP6//JLhE/jzrXNf9j7XdtLC5PQY6I+Hnvtn+zHM6tS5AQ0EUmYO CgEIAK9ngVkokQODNys/daaO/MnilU2b4iqf2FeDlRcobs9umfzUdEJeYvPLu7iC G0HvDfy//bIMoNU8YfgTs98HGOsK4GLZLj4dzzq+3zbJN0xFt59TcvucmM6gLFXi VFg9/wMoj35/uko/wAOUMrGnQAl+Okpy5ller4ZF0bp23V8aW+eGmX+4qXahakyp zz3G7e6+9rXPi6whrYwUl9aT41lcRCsM8cEhBRxxDqQjf6hkKmvTVP4oIMDUeiKd j4FqcdyEXFN2OSUqp4GPaXZ2d7Uzc4+BsIOSPTUVH9m018XdIqqzwo7NSumb3Mug QHfxDA5gu8qjIMobGe6ouGIwOCsAEQEAAYkBHwQYAQIACQUCUmYOCgIbDAAKCRB3 avDaCo9R5L/SB/0RPXsfh5acfV9OdHGy9/xjwWH8sgnoVOJxlE46+Df+4I9w/wlz tLuXqHzyIJ5m9cYbapIFmRxYj7utsTD1vvnNLiSvjYn84WHQ2pyalhgLL49AJ6lZ GEETIDhK2kE4bt2EGDUDNmJFgl42s5gn6pJbbTEjIAqBVVRgJar5x/c7Y/KaM5OY 57hsQrRfI0R91OMp157L/AJeAGaDr+d/5jcCq83cj8U5IKKIX/Dts9hj3yshJ8Fn 0p7xNyzEKDGn0f0WKI3nr6DEvuFjEH1IYqY+526PW8Plp32+h5fk/cIhhhTeDZF2 48+mQTYRWZ6lHYZ08a2SwlUd1yafBWcxQXdP =ePfv -----END PGP PUBLIC KEY BLOCK-----
3. 使用 GPG 加密电子邮件
Outlook
要在 Outlook 中加密您的邮件,您需要安装一个插件。请注意, 新版 Outlook (New Outlook) 目前不支持 GpgOL 插件,因此也不支持 GPG.
对于经典版 Outlook (Classic Outlook),请按以下步骤操作:
安装插件
- 下载 Gpg4win: https://www.gpg4win.de/ (外部链接)查询该信息。
- 安装该软件,并确保同时勾选安装了 Outlook 插件 GpgOL 。
- 打开程序 Kleopatra (随软件自动安装)。
请注意,我们无法控制外部工具的开发,也不对此承担任何责任。
创建密钥
- 在右上角点击 文件 (File) > 新建 OpenPGP 密钥对 (New OpenPGP Key Pair)。
- 输入您的姓名和电子邮箱地址。
- 选择是否要 使用密码短语 (passphrase) 保护生成的密钥.
- 点击 OK.
- 如果您在第 4 步中勾选了该选项,请立即输入您设定的 密码短语 。
- 生成的密钥随后将显示在列表中。
导入密钥
- 将上方提到的 netcup GPG 公钥保存为 .asc 文件 或复制到您的 剪贴板.
- 点击 文件 (File) > 导入 (Import) 并选择该 .asc 文件。 如果要从剪贴板导入密钥,请点击 工具 (Tools) > 剪贴板 (Clipboard) > 证书导入 (Certificate Import).
加密电子邮件
- 打开 Outlook 并撰写您想要发送的电子邮件。
- 菜单栏中会出现一个 GpgOL 选项卡。
- 点击 加密 (Encrypt) 以加密您的邮件内容。
Thunderbird
创建密钥
- 打开 Thunderbird。
- 打开 设置.
- 点击 账户设置 (Account Settings)。
- 在菜单中点击 端到端加密 (End-To-End Encryption) > OpenPGP 密钥管理器 (OpenPGP Key Manager)。
- 在新窗口中点击 生成 (Generate) > 新建密钥对 (New Key Pair).
- 配置您的设置并点击 生成密钥 (Generate key) 和 确认 (Confirm)。
- 在您的账户设置中启用该密钥,路径为 端到端加密 > OpenPGP > 您的密钥 (End-To-End Encryption > OpenPGP > Your Key).
导入密钥
- 将上方提到的 netcup GPG 公钥保存为 .asc 文件 或复制到您的 剪贴板.
- 前往 端到端加密 (End-To-End Encryption) > OpenPGP 密钥管理器 (OpenPGP Key Manager)。
- 点击 文件 (File) > 从文件导入公钥 (Import Public Key(s) from File) 并选择该 .asc 文件。如果要从剪贴板导入密钥,请点击 编辑 (Edit) > 从剪贴板导入密钥 (Import Key(s) from Clipboard).
- 在域名类型下选择 已接受 (Accepted) 并点击 导入 (Import).
加密电子邮件
- 撰写您想要发送的电子邮件。
- 点击 加密 (Encrypt) (位于顶部菜单栏)。
- 如果收件人的公钥已正确存储并信任,您的邮件现在即已完成加密。